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Chapter 1
Configuration and Compatibility

This chapter provides information on compatibility, licensing, and system requirements for this 
Tanner™ Tools release.
For more information on licensing and system configuration, refer to the Tanner Tools 
Administrator’s Guide.

The exact access date is July 2023.

The following issues are described in this chapter:

Windows Support  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
RHEL Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
SVN Support  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
Licensing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
Shipping Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
Broken Links in PDF Documentation - (MG595892). . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

Windows Support
Tanner Tools are no longer supported on Microsoft® Windows® 7, effective January 2020, 
coinciding with the end-of-life date for Windows 7.
Tanner Tools 2016.2 and lower are no longer supported as of January 2020.

Additional information on supported platforms is available at “Installation and Application 
Requirements” in the Tanner Administrator’s Guide.

RHEL Support
Tanner Tools no longer support RHEL6.8, beginning with the 2021.2 release.

SVN Support
The Tanner 2023.2 major release and subsequent update releases support a minimum SVN 
version of 1.7.14 (RHEL 7.9 version). 
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Licensing
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Licensing
The Tanner Tools are currently installed with Siemens Advanced Licensing Technology 
(SALT) version 2.1.0 and FlexNet licensing version 11.19.0.1.
This release supports the new licensing solution, Siemens Advanced Licensing Technology 
(SALT), and includes new licensing documentation: Siemens Digital Industries Software 
License Server Installation Instructions and Siemens Digital Industries Software Licensing 
Manual for Siemens EDA Products.

If you encounter issues, please install the latest version of licensing software from Support 
Center.

Shipping Files
If you are loading the third-party compatibility Tcl startup scripts, please update the file in your 
startup folder to the latest release version in order to allow the bindkeys associated with the 
custom scripts to be auto-loaded correctly upon startup.
The Tcl startup scripts are sedit_custom_startup.tcl and ledit_custom_startup_tcl. These scripts 
are located in the TannerTools_<version>\FeaturesByTool\S-Edit\BindKeys and the 
TannerTools_<version>\FeaturesByTool\L-Edit\BindKeys directories.

Broken Links in PDF Documentation - 
(MG595892)

Due to enhanced security restrictions with web browser PDF plug-ins, some links do not 
function. Links in HTML documentation are fully functional.
Clicking a link within a PDF viewed in a web browser may result in no action, or it may load the 
title page of the current PDF manual (instead of the intended target in the PDF manual). The 
unresolved link behavior occurs in all web browsers on Windows® and Linux®1platforms. 
Because of this behavior, the navigational experience of PDF manuals is compromised. PDF is 
ideal for printing because of its page-oriented layout.

Use the HTML manuals to search for topics, navigate between topics, and click links to 
examples, videos, reference material, and other related technical content.

For information about Adobe’s discontinued support of Adobe Reader on Linux platforms and 
your available options, refer to Knowledge Article MG596568 on Support Center.

1. Linux® is a registered trademark of Linus Torvalds in the U.S. and other countries.

http://support.mentor.com
http://support.mentor.com
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Chapter 2
2023.2

This chapter contains all of the enhancements and corrected defects for this release.
For more information, refer to the individual product manuals available from the InfoHub 
(Help > Help and Manuals) or from Support Center.

Enhancements for ESI. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
Enhancements for Installer. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
Enhancements for L-Edit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
Enhancements for Library Manager . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
Enhancements for Licensing. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
Enhancements for S-Edit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
Enhancements for T-Spice  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Enhancements for Waveform Viewer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Corrected Problems for ESI . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Corrected Problems for L-Edit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Corrected Problems for Library Manager . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Corrected Problems for S-Edit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Corrected Problems for T-Spice. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
Corrected Problems for Tanner Designer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
Corrected Problems for Waveform Viewer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
Known Problems and Solutions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Enhancements for ESI
This section lists the enhancements available in this release of the ESI application.

• ER 55772 — When ESI <Exit> is performed, if there are any running, stopping, or 
post-processing simulations, then a dialog box is displayed providing the opportunity to 
continue with exit, cancel exit, or wait for ESI to automatically terminate when the 
simulations complete.

Enhancements for Installer
This section lists the enhancements available in the Installer for Tanner tools.
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• ER 55923 — Software is now installed in C:\SiemensEDA by default. Previously the 
software was installed in C:\MentorGraphics. To enable the installer to see older 
MentorGraphics installations so they can be uninstalled, go to Tools > Installation 
Preferences, select the “Target List” tab and add the MentorGraphics folder.

Enhancements for L-Edit
This section lists the enhancements available in this release of the L-Edit application.

• ER 34905 — GDS and OASIS import now support a layermap. 

• ER 37339 — Object Groups are now supported in L-Edit. An object group is a 
collection of objects linked together without creating a new cell. When a group is moved 
(copied, deleted, etc.), all objects in the group will be moved (copied, deleted, etc.). Any 
object type can be a member of a group, including other groups. Nesting of groups can 
therefore be done. Push into a group (Page Down) can also be performed to edit, draw, 
delete, or perform other operations on objects inside a group. Objects outside a group 
can also be added to existing groups, and objects inside of groups can be detached from 
their group.

The “Group” command allows the user to choose between creating a Group, a Cell, or 
an Array if that is possible. The “Ungroup” command previously applied to flattening 
selected instances a single level. The Ungroup command is now called “Ungroup 
Group” operates on Groups, and no longer operates on instances. A more powerful 
“Flatten” command is now available, that allows the user to choose to flatten a single 
level, a specified level, or all levels. Flatten enhancements also includes options to 
flatten the selection or the entire view, excluding cells from specified libraries, and 
flattening arrays into instances as a single level. Other options include selecting results 
and allowing undo, deselecting these options can improve performance.

“Individual Edit Mode” (IEM) allows editing of objects without the constraint of group 
membership. In “Individual Edit Mode” objects in groups may be operated on (moved, 
edited, deleted, etc) directly, without having to push into the group. 

The Selection Manager has been enhanced to show group membership. With 
“Individual Edit Mode” off, groups are shown as a tree, whereas with IEM on, groups 
are shown as a list.

New UPI functions are available to create, move, delete, and perform a variety of 
operations on groups. To avoid confusion with our previous use of the term group/
ungroup for creating cells and flattening cell hierarchy, the following UPI commands 
have been marked as legacy and will no longer run unless the #define 
EXCLUDE_LEDIT_LEGACY_UPI is commented out. Legacy commands cannot be 
run via Tcl/python: LSelection_Group, LSelection_UnGroup, LSelection_Flatten, 
LC_Ungroup, LInstance_Ungroup, LCell_Flatten. These commands replace those 
above and perform similar operations now with the more appropriate naming: 
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LSelection_CreateCell, LSelection_Flatten_Ex22, LC_FlattenOneLevel, 
LInstance_FlattenOneLevel, LCell_Flatten_Ex22.

Note
The new default bindkeys for ungroup group is CTRL+U and for flatten is 
SHIFT+U. As bindkeys are stored in user TCL files, these bindkey assignments 

cannot be automatically created for users that already have CTRL+U assigned to 
ungroup. Therefore, users should reassign CTRL+U to flatten and assign SHIFT+U to 
Ungroup group under Setup > Application > Keyboard tab in the Draw and Group 
Utilities Category.

• ER 39593 — SDL can now designate nets as any type (Power, Ground, Signal, Clock, 
Scan, Reset, Analog, TieHi, TieLo, TieOff). The net type is displayed in the SDL 
Navigator, and is used to correctly identify net type in LEF export. To set the net type, 
right click on the net in the SDL Navigator, and choose “Signal Type”.

• ER 40505 — Interpreted labels are now supported. In particular, instance names with 
interpreted labels “[@instanceName]” are now evaluated.

• ER 45397 — Performance of log window is improved for large amount of data logged. 
This improves performance on any operation that logs many messages to the log 
window. In particular, save after GDS import is improved.

• ER 50305 — A new function has been added to assign power types to selected objects 
within the active layout view. This feature enables users to create patterns for power 
rings, power stripes, and power rails in floorplan layout view, designate them with the 
appropriate types, and export them with the correct syntax in DEF format. Power types 
may be assigned by going to SDL > LEF/DEF > Set Power Type.

• ER 55777 — New UPI functions LLayer_SetParametersEx2022 and 
LLayer_GetParametersEx2022 respectively have been created, similar to the earlier 
versions of those function, but with an additional “ShowInList” variable in the struct, 
which, when set to LTRUE, will set the layer as valid.

• ER 55924 — Selection Manager now has a column to display the Net names of selected 
objects.

• ER 55824 — Library Navigator now has context menu for “Save Selected Libraries, 
same as S-Edit has.

• ER 56131 — L-Edit now has the ability to save placement obstructions, and to export 
them to DEF in the BLOCKAGES section. This allows users to generate placement 
blockages in floorplan layout view. A new Blockage layer has been added to the 
“Special Layers”, and placement obstructions should be placed on this layer. Only boxes 
and rectangular polygons will be saved.

• ER 56140 — GDS and OASIS import and export now automatically find a layer map 
file placed in the library folder. If the user types (or browses) to a file, it is used. If no 
file is specified, but a layermap file with name <LibaryName>.cellmap is found in any 
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of the libraries, it is used. If no file is specified, and no file is detected in any library, the 
GDS numbers in Setup Layers are used.

• ER 57326 — Integration of the RFPro flow has been improved. Starting RFPro from L-
Edit will now automatically launch S-Edit and load the database. Upon completion of 
RFPro, S-Edit will then automatically load the S-Parameter subcircuit created by RFPro. 
A cross platform environment is now supported, with L-Edit and S-Edit on Windows 
and RFPro on Linux.

• ER 57567 — SDL is now able to write a minimal Liberty file needed for PnR tools such 
as Aprisa and Nitro. The streamlined liberty file includes the liberty library name and 
essential cell information. For each cell, it only contains area and pins info, and for pins, 
it only contains direction. The minimal liberty file does not contain timing, power, and 
other data. The Liberty file can be written from SDL > LEF/DEF > Write Minimal 
Liberty.

• ER 57594 — Autogen names changed from <mastername>_Auto_#_# to 
<mastername>_Auto_<md5 hash>. Using the previous naming convention, the same 
autogen could have different names under different conditions. The new name ensures 
that autogen names are stable. AutoGen names are normally hidden in the Library 
Navigator, but can be made visible by Library Navigator Context Menu > Settings > 
Filters > Show Hidden Cells.

• ER 57671 — Many new features have been added to support FinFet technologies. 
FinFet Grids are now rendered on the layout area, and all L-Edit Drawing and Editing 
tools now support snapping to FinFet Grids. Options of how FinFet grids are rendered 
can be customized through the rendering tab of Setup Layer dialog. The new FinFet 
features requires a new license called L-Edit Advanced.

o FinFet Grid Setup: A new FinFet tab in the Setup Layer dialog to visualize the setup 
of FinFet Grid as defined in the iPDK.

o A new command, Setup > WSP > New WSP Def, to define the track pattern of a 
Metal layer routing.

o A new command, Setup > WSP > New WSP Set, to create a collection of WSP 
Definitions

o A new command, Setup > WSP > Generate Layout from WSP Def, to generate 
the corresponding layout view to a WSP Def.

o A new command, Setup > WSP > Generate WSP Def from Layout, to generate a 
WSP Def from a selected layout pattern.

o A new command, Setup > WSP > Export WSP Defs..., to export WSP Defs to a 
CSV file.

o A new command, Setup > WSP > Import WSP Defs..., to import WSP Defs from a 
CSV file.
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o A new command, Draw > Draw WSP Region, to draw a WSP Region to snap 
metal routing to their corresponding tracks inside it.

o New layer operations lets one monitor the visibility, the protection and lock of WSP 
layers independently from the other layers. 

o A FinFet grid toolbar lets one easily enable/disable FinFet snapping, toggle a FinFet 
Display option, enable/disable WSP snapping, and toggle a WSP Display option.

• ER 57856 — Performance opening a lib.defs has been improved by multi-threaded 
reading of the list of views to populate the Library Navigator. Performance 
improvements up to 10x have been accomplished, especially improved for slow 
environments such as reading from a drive over a network. 

• ER 57857 — Flatten has been enhanced with several options, including i) flatten to a 
specified level of hierarchy, ii) flatten selections or active view, iii) allow undo, and iv) 
select results. The last two can improve performance by turning them off. Flatten 
operates on instances hierarchy and does not affect group hierarchy. Objects in an 
instance hierarchy that are in a group will remain in the group after flattening.

• ER 57886 — In cases where there is same cellname in multiple libraries, or the same 
cellname with Multiple views, GDS/OASIS export now names cells as 
<cellname>_<libname>_<viewname> rather than simply appending a digit on the 
cellname. Viewname is omitted if the viewname is “layout”.A cellmap file is also 
written on GDS Export, both when GDS/OASIS is explicitly exported via File > Export 
Mask Data > GDS/OASIS, and also when GDS/OASIS is written for Calibre. Calibre 
RVE will be able to use this cellmap file to resolve ambiguous cellnames, starting in 
their 2023.4 release.

Enhancements for Library Manager
This section lists the enhancements available in this release of the Library Manager application.

• ER 52288 — Library Manager now has an option to allow a user to select two 
schematic or symbol views and launch S-Edit Compare for these two views and display 
the differences.

• ER 57739 — Library Manager is able to open any config view to launch S-Edit with 
SDE. 

Enhancements for Licensing
This section lists the enhancements available for licensing in the Tanner tools.

• ER 56283 — The dialog box that appears when there is a license failure on starting now 
has information about license servers defined, and if they could be connected. 



Tanner™ Tools Release Notes, v2023.214

2023.2
Enhancements for S-Edit

Note - Viewing PDF files within a web browser causes some links not to function. Use HTML for full navigation.

• ER 56808 — Tanner Tools has been upgraded to use SALT Licensing Version 2.1.0.  
Clients using SALT 2.0 or greater require upgrading to Siemens License Server 2.x or 
greater.

Enhancements for S-Edit
This section lists the enhancements available in this release of the S-Edit application.

• ER 33814 — Import Spice/CDL and Import Verilog have been enhanced to generate a 
schematic from the imported netlist. Symbols are placed in a grid and connections are 
formed by placing netlabels on pins. There are no wires in the generated schematic, 
however the schematic can be used for subsequent netlisting and LVS, now with the 
PDK symbol and all its properties. For Spice import, a mapping file containing the 
subcircuit definitions can be specified to obtain the pinorder mapping. For import of 
primitive devices (transistors, etc) a Calibre cellmap file containing Lib-Cell-View 
mappings as well as property and pinorder mappings can be specified. 

• ER 48572 — Added check to design check #14 to warn user when CDF or other term 
order is inconsistent with an interface.

• ER 49190 — A warning is now issued if trying to close S-Edit while an Eldo, AFS, or 
Symphony simulation is running, and giving the user a chance to proceed or cancel. 

• ER 51685 — Performance of log window is improved for large amount of data logged. 
This improves performance on any operation that logs many messages to the log 
window. In particular, performance of small AFS simulations where logging would take 
more time than simulation is improved.

• ER 52157 — A new dialog box has been added to AFS PSS Noise Analysis for setup of 
Jitter Measurements.

• ER 55104 — Testbench setup has been enhanced to give greater control over where 
additional commands can be placed in the netlist. Additional commands can now be 
placed in a tab corresponding to any of the following places: i) Beginning of file, ii) 
Before Design, iii) After Design, iv) After Analysis, v) with each corner, vi) end of file. 
Additional Commands from prior releases will be placed in a tab called “Legacy”.

• ER 55550 — A field to provide a list of libraries to exclude from validation has been 
added to the Setup > Design Checks > Validation pane.

• ER 55938 — The 'Simulation completed with <n> warnings ...' message is now always 
displayed in the S-Edit log. A TCL command “tsp log -log <logfilename> -summary” 
displays the summary information for the simulation.

• ER 56912 — Changed aspect ratio of File > Export > Spice/Spectre dialog box to 
better fit on small displays.

• ER 57476 — CDL Import now supports the $PINS syntax for specifying pins.
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• ER 57529 — The default value of Design Check #24 – “Overlapping netlabel and pin” 
has been changed from “Warning” to Ignore”. Importing a netlist to Schematic, as well 
as importing a Calibre View, will create symbols with netlabels on the pins, and these 
should not generate a warning.

• ER 57621 — AFS simulations now use the --ovd command line argument. Simulations 
that have Results page expressions containing the EZwave waveform syntax wf("<sim/
Folder>Wavename") will need to be converted to the syntax var("Wavename", 
"Folder"). Folder is typically OP or STB.

• ER 57833 — Solido Design Environment (SDE) is now integrated in S-Edit. SDE 
provides enhanced simulation setup options over the built-in Tanner Design 
Environment (TDE). Users needing chained simulations, trimming, and distributed 
processing will be interested in SDE. SDE’s Variation Designer provides advanced 
simulation features such as Hierarchical Montecarlo for full-chip memory statistical 
variation, High-sigma Montecarlo, Fast PVT for verification across corners, high-sigma 
verification, variation-aware design sensitivity, and automated variation aware cell-level 
optimization.

A button on the Run Simulation toolbar allows users to choose between operating in 
SDE mode or in TDE mode. A new Config view has been added to S-Edit with a Config 
View Editor, to allow users to specify the view hierarchy for SDE when multiple views 
of a cell exist. The config view editor allows specification of Global Binding priority 
with a Library List, View List, and Stop List. Cell Bindings may be specified either in a 
tree view or table view by directly specifying the view to use, or use the inherited view 
list from the Global Bindings. The schematic view for the config view may be opened 
from the config view, using the hierarchy context of the config view.

A new Setup SDE page has been added to allow specification of default View List and 
Stop Lists as well as Model files and other Simulation and netlisting parameters. 

A new SDE view has also been added to S-Edit. The SDE view stores the setup 
information for the SDE Testbenches. The Simulation Toolbar has been split into two 
toolbars, the Run Simulation toolbar, and the Simulation Results toolbar. In SDE mode 
the Run Simulation toolbar contains two dropdown controls, the first lists all SDE state 
views in the cell of the active view, and the second lists all config views in the cell of the 
active view. In TDE mode, there is a single drop down control that lists the testbenches 
for the active view, as well as Run and Stop Buttons, and a display of the number of 
errors and warnings for the last simulation.

The Simulation Results toolbar contains controls for Opening the Netlist and warning 
logs, as well as for probing and operating point display. 

• ER 57840 — Many enhancements have been made to Setup Simulation for AFS RF 
simulation for Harmonic Balance Analysis and PSS Analysis. New setup pages have 
been created for the following:

o •HB S-Parameter Analysis
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o •HB Stability Analysis

o •HB Transfer Function Analysis 

o •PSS S-Parameter Analysis

• ER 57841 — Many enhancements and improvements have been made to various Setup 
Simulation, including Simulation Options, DC Operating Points analysis, DC Sweep, 
Monte Carlo, AC Analysis, Noise Analysis, Stability analysis, Temperature Sweep, DC 
Mismatch analysis, and Corner Analysis.

• ER 57856 — Performance opening a lib.defs has been improved by multi-threaded 
reading of the list of views to populate the Library Navigator. Performance 
improvements up to 10x have been accomplished, especially improved for slow 
environments such as reading from a drive over a network. 

Enhancements for T-Spice
This section lists the enhancements available in this release of the T-Spice application.

• ER 40823 — Improved multi-threaded performance on Linux.

• ER 41799, 40850 — T-Spice simulation performance has been improved on Linux, 
especially for temperature and parameter sweeps.

Enhancements for Waveform Viewer
This section lists the enhancements available in this release of the Waveform Viewer 
application.

• ER 24207 — Voltage probing from S-Edit to either Waveform Viewer or EZWave will 
now color the net in S-Edit and the waveform the same color. Changing the color of the 
net will also subsequently change the color of the waveform.

Corrected Problems for ESI
This section lists the fixed defects in this release of the ESI application.

• DR 54245 — The version of Putty installed with Tanner Tools has been upgraded to 
0.78, providing compatibility with PPK version 2 and 3 private key formats.

• DR 56235 — DISPLAY (and all Environment variables) is now treated as case 
insensitive in ESI. 

• DR 56653 — Fixed problem saving ESI settings to the registry. 

• DR 56992 — Fixed problem in ESI resulting in the message, "Error: could not open 
file" when running a MC simulation.
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Corrected Problems for L-Edit
This section lists the fixed defects in this release of the L-Edit application.

• DR 53062 — Fixed problem on Linux where many commands such as New Design, 
Open etc. menus and Command window would default to a random path instead of the 
directory the tools are launched from.

• DR 54217 — DEF Export now writes extension values for all coordinates of a wire with 
"End Style" set to Extend. Previously on the endpoint vertices had extension values 
written.

• DR 55601 — Tori and Arcs are now exported to ODB++.

• DR 55742 — Pick Layer now works when editing in place but picking a layer outside 
the cell you are editing in place.

• DR 55836 — Fixed problem on GDS import, when there are two layout views for a cell 
in "Search cells in" library, GDSII import uses different layout views randomly. Also, 
views named “Layout” are now given priority.

• DR 55868 — The net name of an object is now visible and editable on the Edit Objects 
dialog box.

• DR 55965 — GDSII Import "Search for cells in" is now updated correctly when the 
value is deleted.

• DR 56032 — Invoking Custom Layer Palette dialog will no longer reset the current 
palette, even after Cancel.

• DR 56115 — Temporary rulers no longer disappear while moving instances.

• DR 56293 — Improved Performance of Cell Copy with hierarchy when the top cell is 
open.

• DR 56582 — Fixed issue where SDL > Check Connectivity was incorrectly reported 
in the Verification Error Navigator when multiple views of the cell were present.

• DR 56612 — Fixed a problem where Mask Bias would assign data type.

• DR 56737 — Fixed a problem where the GDS numbers in Setup layers were used 
instead of the GDS layermap file for GDS Export during LVS. 

• DR 56793 — Fixed problem where TCL parameters defined on a T-Cell were missing 
when the T-Cell was instanced.

• DR 56957 — In Draw > Convert > Snap to grid, instances, vias, and circles are now 
correctly snapping to the Mouse Grid.

• DR 56958 — Fixed command line -U option. Command line scripts (-u, -U, -t, -T, 
filename) are now executed in the order they appear on the command line, in both L-
Edit and S-Edit.
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• DR 57256 — Fixed problem where after using Duplicate and auto-increment, the entire 
set could not be renamed to the initial label if the rename is to the first value of the 
sequence.

• DR 57360 — Improved performance of loading and refreshing layer palettes when there 
are a very large number of Layer-Purpose-Pairs. Layer Palette data is now stored in 
%appdata% in the L-Edit/SetupDesign/<design>/LayerPalettes folder. This allows 
palettes to be shared between users.

• DR 57598 — Fixed problem when editing an object in L-Edit (Ctrl-E) to modify the 
number of columns or rows (usually a via array), if the existing value is deleted a pop-up 
error is immediately displayed saying "Enter an integer".

Corrected Problems for Library Manager
This section lists the fixed defects in this release of the Library Manager application.

• DR 46365 — Fixed issue where opening a new schematic view from Library Manager 
gives *.tmp cell not found error if a schematic view is already open.

Corrected Problems for S-Edit
This section lists the fixed defects in this release of the S-Edit application.

• DR 47674 — Improve performance loading large schematics with inherited 
connections. 

• DR 48910 — Long delay from the end of AFS simulation until "Simulation finished" 
message and EZwave launch is resolved.

• DR 49638 — When exporting a netlist for Symphony simulations, empty subcircuit 
definitions are now generated for digital blocks, in order to support the mapping of pins 
by name.

• DR 51581 — Fixed problem where Import Spice with Parse Connectivity results in 
“missing port(s)” errors.

• DR 52051 — Fixed problem where tooltips over the simulation progress bar did not 
always appear.

• DR 52503 — Signals with wildcard in Setup Simulation > Results page now works for 
AFS simulation.

• DR 53059 — Fixed problem on Linux where many commands such as New Library, 
and also the Command window, default to a random path instead of the directory the 
tools are launched from.

• DR 54642 — Prevent crash when saving after renaming a cell by changing case only.
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• DR 54683 — Fixed problem where Netset property assignment does not get exported to 
SPICE, unless the design is closed and reopened.

• DR 55061 — Testbench field is now updated after duplicating, renaming or deleting it 
on Properties window or by tcl.

• DR 55363 — Fixed problem where shorting inherited nets on top level caused shorts in 
subcircuit and incorrect evaluation of inherited nets in schematic.

• DR 55620 — On Linux, "Pick from schematic" under all applicable AFS Analyses' 
fields in Sim Setup can now be canceled.

• DR 55731 — ClioSoft error messages are now sent to the command window.

• DR 55876 — Fixed problem where Renamed Property names disappeared from the 
properties navigator when "Query" is checked.

• DR 56019 — The Stop Simulation behavior has changed so that the first press will 
attempt a graceful stop that releases licenses and closes files, while a second press will 
forcefully terminate the simulation.

• DR 56174 — Fixed problem where DC result annotation disappeared or cut off while 
panning around the schematic with the keyboard arrow keys.

• DR 56180 — Double-clicking on a label and then approving the dialog box no longer 
results in shifting of the entire label.

• DR 56194 — Deleted views are now ignored in design check as both views to check, 
and as views to check against.

• DR 56270 — Fixed reading of OpenAccess cdsTerm labels written by Custom 
Compiler so “annotate port” no longer appears. Replace [] with <> in port names, net 
labels, and evaluated labels.

• DR 56319 — Fixed issue where "Save All" took longer when the design is in SVN 
working copy and not managed compared to the design which is out of working copy.

• DR 56790 — Several import issues fixed and more data is now imported from ADE 
state files into Setup Simulation.

• DR 56823 — Fixed warning from '24 Overlapping net label and pin' when net label is 
overlapping text label in a symbol.

• DR 56897 — EZwave is now brought to the foreground when probing from schematic.

• DR 57220 — In Setup Simulation, on all pages, all controls on the "Value" side (RHS) 
of the setup table are now consistently displayed in English, even when in Japanese 
mode. These correspond to simulator options and so they are in English. This cases 
situations where fields were enabled/disabled incorrectly in Japanese mode.

• DR 57412 — Fixed problem in import of CalibreViews case of properties was not being 
imported correctly.
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• DR 57528 — Corrected EZwave error “The file <name> cannot be opened” when S-
Edit Waveform viewing is set to ‘During’ for an AFS simulation.

• DR 57606 — Corrected a Windows to Linux EZwave probing failure with error 
message “The file <name> cannot be found”, when the simulation results folder name 
begins with a slash.

Corrected Problems for T-Spice
This section lists the fixed defects in this release of the T-Spice application.

• DR 52436 — Corrected BSIM4 cgtot, total gate capacitance, printed values (internal 
capacitance values were correct).

• DR 52761 — Fixed a .measure error ‘boost::bad_get: failed’ when measurement result 
values are chained into the expression for a subsequent measurement.

• DR 53154 — Enable use of named .print values within measurement calculations.

• DR 57109 — Recognize // as a comment line in netlists.

• DR 55631 — Corrected DC Sweep hysteresis simulation results which under some 
circumstances did not show hysteresis effects.

• DR 55815 — Corrected some noise contribution terms for M multiplicity scaling with 
VBIC, JFET, MesFet, EKV, and bipolar devices.

• DR 56482 — Fixed memory leaks and reduced memory consumption with some device 
models.

• DR 56559 — Corrected Rise=Last measurements that were ‘Not Found’ under certain 
circumstances.

• DR 57295 — String parameter declarations will now support str(<param_name>) 
syntax used by some PDKs.

• DR 57497 — Added support for auto-completion in the T-Spice editor using 
<Ctrl><Space> keystroke.

Corrected Problems for Tanner Designer
This section lists the fixed defects in this release of the Tanner Designer application.

• DR 53224 — The grouping of Monte Carlo measurement results into Data Sets has 
been corrected for certain circumstances.

• DR 55597 — The Waveform Viewer button will now open Eldo simulation results 
using display formatting specified in the associated .swd file
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Corrected Problems for Waveform Viewer
This section lists the fixed defects in this release of the Waveform Viewer application.

• DR 38715 — Fixed problem where moving magnitude curves of a complex trace onto a 
different plot would show the deg component on the new plot.

• DR 56052 — The menu accelerator key bindings to drop down menus have been 
removed from the Japanese menus.

• DR 56171 — Bindkeys “Zoom In” and “Zoom Out” have been changed to “Zoom In 
Horizontal Around Center” and “Zoom In Horizontal Around Center”. Defaults 
bindkeys for Zoom In Horizontal Around Center is “]” and for Zoom In Horizontal 
Around Center is “[“. As with all bindkeys, these can be custom bound to any key as 
user prefers.

• DR 57741 — Bindkey for Save Chartbook, “Ctrl+S”, is now persistent between 
sessions.

• DR 55996 — Bindkeys for Chart > Move Curves > Up/Down are now persistent 
between sessions.

Known Problems and Solutions
This section lists known problems and solutions in this release.

• Custom presentation of Library/Cell/View names is available in the L-Edit and S-Edit 
tools, but is not yet available in the Library Manager tool.

• DR 57098 — Implicit Selection is not currently available on groups.

• DR 57382 — The "database layers" TCL command now lists the layers in the database 
and their layer number. The old “database layers” command that listed layer-purpose 
pairs, is now called "database lpps". Scripts using “database layers” will need to be 
updated to use the new command. A -tcl option has been added to the “database lpps” 
command to output all lpps to a tcl script to save rendering attributes for lpps.

• DR 57665 — When you run an SDE test across corners and annotate individual corners' 
DC OP results, S-Edit displays only the first set of annotations. Any subsequent corner 
annotations fetch the same (previous) results. There is no work-around for this issue, and 
it will be fixed in a future product release.
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Global Customer Support and Success
A support contract with Siemens Digital Industries Software is a valuable investment in your 
organization’s success. With a support contract, you have 24/7 access to the comprehensive and 
personalized Support Center portal.
Support Center features an extensive knowledge base to quickly troubleshoot issues by product 
and version. You can also download the latest releases, access the most up-to-date 
documentation, and submit a support case through a streamlined process.

https://support.sw.siemens.com

If your site is under a current support contract, but you do not have a Support Center login, 
register here:

https://support.sw.siemens.com/register

Documentation
These release notes and the accompanying Tanner Tools documentation are available through 
multiple resources.
View the Tanner Tools documentation from the following locations:

• Application help through the Help > Help and Manuals to invoke the InfoHub 
documentation portal.

• On Support Center under the Documentation tab for Tanner Tools releases.

https://support.sw.siemens.com
https://support.sw.siemens.com/register
https://support.mentor.com
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Third-Party Information
Details on open source and third-party software that may be included with this product are available in the
<your_software_installation_location>/legal directory.
Note - Viewing PDF files within a web browser causes some links not to function. Use HTML for full navigation.
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