
Software Version 2022.2 
Document Revision 1

SIEMENS EDA

Tanner™ Tools Release 
Notes



Unpublished work. © 2022 Siemens

This Documentation contains trade secrets or otherwise confidential information owned by Siemens Industry 
Software Inc. or its affiliates (collectively, “Siemens”), or its licensors. Access to and use of this Documentation is 
strictly limited as set forth in Customer’s applicable agreement(s) with Siemens. This Documentation may not be 
copied, distributed, or otherwise disclosed by Customer without the express written permission of Siemens, and may 
not be used in any way not expressly authorized by Siemens.

This Documentation is for information and instruction purposes. Siemens reserves the right to make changes in 
specifications and other information contained in this Documentation without prior notice, and the reader should, in 
all cases, consult Siemens to determine whether any changes have been made.

No representation or other affirmation of fact contained in this Documentation shall be deemed to be a warranty or 
give rise to any liability of Siemens whatsoever.

If you have a signed license agreement with Siemens for the product with which this Documentation will be used, 
your use of this Documentation is subject to the scope of license and the software protection and security provisions 
of that agreement. If you do not have such a signed license agreement, your use is subject to the Siemens Universal 
Customer Agreement, which may be viewed at https://www.sw.siemens.com/en-US/sw-terms/base/uca/, as 
supplemented by the product specific terms which may be viewed at https://www.sw.siemens.com/en-US/sw-
terms/supplements/.

SIEMENS MAKES NO WARRANTY OF ANY KIND WITH REGARD TO THIS DOCUMENTATION INCLUDING, 
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR 
PURPOSE, AND NON-INFRINGEMENT OF INTELLECTUAL PROPERTY. SIEMENS SHALL NOT BE LIABLE 
FOR ANY DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL OR PUNITIVE DAMAGES, LOST DATA OR 
PROFITS, EVEN IF SUCH DAMAGES WERE FORESEEABLE, ARISING OUT OF OR RELATED TO THIS 
DOCUMENTATION OR THE INFORMATION CONTAINED IN IT, EVEN IF SIEMENS HAS BEEN ADVISED OF 
THE POSSIBILITY OF SUCH DAMAGES.

TRADEMARKS: The trademarks, logos, and service marks (collectively, "Marks") used herein are the property of 
Siemens or other parties. No one is permitted to use these Marks without the prior written consent of Siemens or the 
owner of the Marks, as applicable. The use herein of third party Marks is not an attempt to indicate Siemens as a 
source of a product, but is intended to indicate a product from, or associated with, a particular third party. A list of 
Siemens' Marks may be viewed at: www.plm.automation.siemens.com/global/en/legal/trademarks.html. The 
registered trademark Linux® is used pursuant to a sublicense from LMI, the exclusive licensee of Linus Torvalds, 
owner of the mark on a world-wide basis.

About Siemens Digital Industries Software

Siemens Digital Industries Software is a leading global provider of product life cycle management (PLM) software 
and services with 7 million licensed seats and 71,000 customers worldwide. Headquartered in Plano, Texas, 
Siemens Digital Industries Software works collaboratively with companies to deliver open solutions that help them 
turn more ideas into successful products. For more information on Siemens Digital Industries Software products and 
services, visit www.siemens.com/plm.

Support Center: support.sw.siemens.com 
Send Feedback on Documentation: support.sw.siemens.com/doc_feedback_form 

https://www.sw.siemens.com/en-US/sw-terms/base/uca/
https://www.plm.automation.siemens.com/global/en/legal/trademarks.html
https://www.siemens.com/plm
https://support.sw.siemens.com/
https://support.sw.siemens.com/doc_feedback_form
https://www.sw.siemens.com/en-US/sw-terms/supplements/
https://www.sw.siemens.com/en-US/sw-terms/supplements/


Revision History

Author: In-house procedures and working practices require multiple authors for documents. All 
associated authors for each topic within this document are tracked within the Siemens 
documentation source. For specific topic authors, contact Siemens Digital Industries Software 
documentation department.

Revision History: Released documents include a revision history of up to four revisions. For 
earlier revision history, refer to earlier releases of documentation on Support Center.

Revision Changes Status/
Date

1 Modifications to improve the readability and comprehension of 
the content. Approved by Lucille Woo.

All technical enhancements, changes, and fixes are listed in this 
document for all products in this release. Approved by Barry 
Dyne.

Released 
June 2022
Tanner™ Tools Release Notes, v2022.2

Note - Viewing PDF files within a web browser causes some links not to function. Use HTML for full navigation.



Tanner™ Tools Release Notes, v2022.24

Note - Viewing PDF files within a web browser causes some links not to function. Use HTML for full navigation.



Table of Contents

Revision History

Chapter 1 
Configuration and Compatibility  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

Windows Support  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
RHEL Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
Licensing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
Shipping Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
Broken Links in PDF Documentation - (MG595892) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

Chapter 2 
2022.2 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

Known Problems and Solutions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
Enhancements for Installer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
Enhancements for L-Edit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
Enhancements for Library Manager  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Enhancements for Linux . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Enhancements for Revision Control  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Enhancements for S-Edit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Enhancements for Tanner Designer. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
Enhancements for Waveform Viewer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
Corrected Problems for L-Edit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Corrected Problems for Library Manager . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Corrected Problems for Linux . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Corrected Problems for Revision Control . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Corrected Problems for S-Edit. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
Corrected Problems for T-Spice  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
Corrected Problems for Tanner Designer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
Corrected Problems for Waveform Viewer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

Chapter 3 
Getting Help  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23

Global Customer Support and Success  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23
Documentation. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23

Third-Party Information
Tanner™ Tools Release Notes, v2022.2 5



Table of Contents
6 Tanner™ Tools Release Notes, v2022.2



Tanner™ Tools Release Notes, v2022.2 7

Note - Viewing PDF files within a web browser causes some links not to function. Use HTML for full navigation.

Chapter 1
Configuration and Compatibility

This chapter provides information on compatibility, licensing, and system requirements for this 
Tanner™ Tools release.

For more information on licensing and system configuration, refer to the Tanner Tools 
Administrator’s Guide.

The exact access date is June 2022.

The following issues are described in this chapter:

Windows Support  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

RHEL Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

Licensing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

Shipping Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

Broken Links in PDF Documentation - (MG595892). . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

Windows Support
Tanner Tools are no longer supported on Microsoft® Windows® 7, effective January 2020, 
coinciding with the end-of-life date for Windows 7.

Tanner Tools 2016.2 are no longer supported as of January 2020.

Additional information on supported platforms is available at “Installation and Application 
Requirements” in the Tanner Administrator’s Guide.

RHEL Support
The Tanner 2021.2 release is the last release to support RHEL 6.8. Future major Tanner releases 
will only support RHEL 7.

Licensing
The Tanner Tools are currently installed with Mentor Standard Licensing version 2018_1 and 
FlexNet licensing version 11.14.1.3.
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If you encounter issues, please install the latest version of licensing software from Support 
Center.

Shipping Files
If you are loading the third-party compatibility Tcl startup scripts, please update the file in your 
startup folder to the latest release version in order to allow the bindkeys associated with the 
custom scripts to be auto-loaded correctly upon startup.

The Tcl startup scripts are sedit_custom_startup.tcl and ledit_custom_startup_tcl. These scripts 
are located in the TannerTools_<version>\FeaturesByTool\S-Edit\BindKeys and the 
TannerTools_<version>\FeaturesByTool\L-Edit\BindKeys directories.

Broken Links in PDF Documentation - 
(MG595892)

Due to enhanced security restrictions with web browser PDF plug-ins, some links do not 
function. Links in HTML documentation are fully functional.

Clicking a link within a PDF viewed in a web browser may result in no action, or it may load the 
title page of the current PDF manual (instead of the intended target in the PDF manual). The 

unresolved link behavior occurs in all web browsers on Windows® and Linux®1platforms. 
Because of this behavior, the navigational experience of PDF manuals is compromised. PDF is 
ideal for printing because of its page-oriented layout.

Use the HTML manuals to search for topics, navigate between topics, and click links to 
examples, videos, reference material, and other related technical content.

For information about Adobe’s discontinued support of Adobe Reader on Linux platforms and 
your available options, refer to Knowledge Article MG596568 on Support Center.

1. Linux® is a registered trademark of Linus Torvalds in the U.S. and other countries.

http://support.mentor.com
http://support.mentor.com
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Chapter 2
2022.2

This chapter contains all of the enhancements and corrected defects for this release.

For more information, refer to the individual product manuals available from the InfoHub 
(Help > Help and Manuals) or from Support Center.

Known Problems and Solutions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

Enhancements for Installer. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

Enhancements for L-Edit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

Enhancements for Library Manager . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Enhancements for Linux . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Enhancements for Revision Control  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Enhancements for S-Edit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Enhancements for Tanner Designer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

Enhancements for Waveform Viewer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

Corrected Problems for L-Edit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

Corrected Problems for Library Manager . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

Corrected Problems for Linux . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

Corrected Problems for Revision Control. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

Corrected Problems for S-Edit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

Corrected Problems for T-Spice. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Corrected Problems for Tanner Designer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Corrected Problems for Waveform Viewer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

Known Problems and Solutions
The following known problems and solutions are present in this release.

• The custom presentation of Library/Cell/View names is available in the L-Edit tool and 
the S-Edit tool, but is not yet available in the Library Manager tool.

Enhancements for Installer
The following enhancements are available for the installer in this release.
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• ER 39835 — Installing with the -batch command line argument will now install desktop 
shortcuts without asking for user input.

Enhancements for L-Edit
This section lists the enhancements available in this release of the L-Edit application.

• ER 29064 — A new Layer Operations menu in the Layer Palette lets one easily select or 
delete objects on the layers selected in the Layer Palette. Instances containing the 
specified layers can also be selected. Deletion of objects on the specified layers can be 
done in the active cell, in the hierarchy of the active cell, or in all cells. 

• ER 46215 — A Selection Manager in L-Edit lets you easily see the list of objects 
selected, highlight the selected objects on layout, remove objects from the selection list, 
and delete selected objects from layout. 

• ER 50938 — The format of the Library/Cell/View name when referencing a view is 
now customizable. You can choose from four preset choices on the Setup 
Application > Format dialog box, or you can customize your own format with a small 
tcl function. 

• ER 53023 — The number of warnings issues by GDS/OASIS import and export is now 
limited to 100 warnings of each type. This can significantly improve performance for 
designs with large numbers of warnings.

• ER 53054 — A button to toggle label selectabilty has been added under the Layer 
Palette, along with the previous buttons to toggle selecatability of instances, vias, and 
ports.

• ER 53058 — A new command Edit > Select > Select Under Point selects all objects 
under a point with a single mouse click.

• ER 53193 — Performance populating the list of cellviews in a library in the Library 
Navigator when opening a lib.defs file can now be improved by creating an index of the 
cellviews in the library. This can produce significant performance improvements for 
very large libraries on a network drive. The script for creating the index file is called 
mkindex.py and is located in the LinuxUtils folder. This feature is suitable for static 
libraries in which the list of views do not change.

• ER 53574 — L-Edit can be setup for 2-button mouse operation using a new option “Use 
Alt key to emulate three-button mouse” in Setup Application > Mouse.

• ER 53793 — UPI commands are now available for Alignment Toolbar functions.

• ER 53976 — The Enable Rule-Aware Layout and Setup Rule-Aware Layout 
buttons on the Verification toolbar have been moved to the Object Snapping toolbar, and 
the Verification toolbar has been renamed to MEMS Verification toolbar.
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• ER 54495 — Running a custom TCL script on program startup/shutdown, and database 
open/close is now supported in all tools. Scripts may be located in a “scripts” folder in 
the database folder, in %AppData%\Tanner EDA (Windows), $HOME/.tanner/config 
(Linux), or in a folder given by an environment variable 
$TANNER_TCL_AUTOLOAD_DIR.

• ER 54732 — The Calibre Realtime integration from L-Edit now supports the runset 
feature. To use the runset feature in Calibre RealTime, you need to upgrade to Calibre 
2022.2_15 or later.

• ER 54875 — The Draw > Add Wire Section command now lets you draw a rectangle 
to push selected wires aside to make room for other objects. The wires wrap around the 
rectangle maintaining their spacing as the rectangle is resized.

• ER 54928 — User preferences and technology have been separated. User preferences 
are now saved in the registry and not in technology, and modifying user preferences will 
no longer mark the tech as modified. Settings in the Setup Design dialog box are user 
preferences. In the Setup Technology dialog box, the Rule Aware Layout and Node 
Highlighting tabs also contain user preferences inside a groupbox labeled Settings.

Table 2-1. L-Edit Script Order 

Program startup scripts run in the following 
order . . .

Design open scripts run in the following 
order . . .

1. The bindkey script file, 
layout_bindkeys_utf8.tcl, is loaded from 
%appdata%\Tanner EDA (Windows) or 
$HOME/.tanner/config (Linux).

2. User scripts from 
$TANNER_TCL_AUTOLOAD_DIR/
startup.ledit folder. 
$TANNER_TCL_AUTOLOAD_DIR is a 
user defined environment variable containing 
a path.

3. User scripts from folder in %appdata%/
Tanner EDA/scripts/startup.ledit (Windows) 
or $HOME/.tanner/config/scripts/
startup.ledit (Linux).

4. Command line scripts (–t <filename>) and 
command line TCL commands (–T <“TCL 
Commands”>) – in order they appear on the 
command line.

5. Command line design open (lib.defs open).

1. The autoLoad.tanner script from each 
library folder.

2. Scripts in the ./scripts/open.layout folder 
each library folder.

3. Scripts in the .scripts/open.layout folder 
in lib.defs folder.

4. Scripts in 
$TANNER_TCL_AUTOLOAD_DIR/
open.layout .

5. Scripts in %appdata%/Tanner EDA/
scripts/open.layout (Windows) or 
$HOME/.tanner/config/scripts/
open.layout (Linux).
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Enhancements for Library Manager
This section lists the enhancements available in this release of the Library Manager application.

• ER 53630 — Running a custom TCL script on program startup/shutdown, and database 
open/close is now supported in all tools. Scripts may be located in a “scripts” folder in 
the database folder, in %AppData%\Tanner EDA (Windows), $HOME/.tanner/config 
(Linux), or in a folder given by an environment variable 
$TANNER_TCL_AUTOLOAD_DIR.

• ER 53745 — Enhanced hierarchical copy for cells and library to copy the whole cells.

• ER 53802 — Improved performance opening lib.defs in Library Manager.

• ER 54138 — Library Manager is now able to show which views are instantiated using 
the library report, cell report, and view report tcl commands.

• ER 54458 — Version control columns in Library Manager are now autopopulated.

Enhancements for Linux
This section lists the enhancements available on Linux in this release.

• ER 52980 — anner Tools data in %AppData% on Windows is now stored in $HOME/
.tanner/config on Linux.

Enhancements for Revision Control
This section lists the enhancements available for Revision Control in this release.

• ER 55180 — A TCL Callback interface has been developed for custom Version Control 
Integration.

Enhancements for S-Edit
This section lists the enhancements available in this release of the S-Edit application.

• ER 42059 — Schematic P-Cells are now supported. For example, parameters on a 
symbol can be used to update the number of pins on the symbol, and the underlying 
schematic will be automatically generated.

• ER 47715 — L-Corner drawing mode draws an L shaped wire from the last vertex. 
L-Corner mode now preserves the direction of the segment as you move the mouse away 
from a vertex, allowing you to easily connect two points with a minimum of clicks. You 
can press the L key to flip the orientation of the L while drawing the wire.
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• ER 47616 — The small signal parameter list can now be sorted by clicking on the 
column header in the table.

• ER 50358 — Corner setup now allows multiple variables with the same library name. 
These are netlisted in the same Alter.

• ER 50939 — The format of the Library/Cell/View name when referencing a view is 
now customizable. You can choose from four preset choices on the 
Setup > Preferences > Format page, or you can customize your own format with a 
small tcl function.

• ER 52524 — S-Edit is now able to import PEX/xAct netlist views and create a 
schematic view containing both the intentional and parasitic devices. A cellmap file is 
used to provide the mapping to the correct symbols. Device properties from the netlist 
are applied 

• ER 53088 — Three new buttons are added to the Setup Simulation > Results page for 
adding Voltage, Current, and Differential Probe signals to the signals table. Pressing 
these buttons allows addition of multiple signals at one time by clicking on each signal 
on the schematic. 

• ER 53100 — The number of significant digits or decimals displayed in annotations on 
schematic views can now be controlled using new number format settings on 
Setup > Preferences > Format.

• ER 53193 — Performance populating the list of cellviews in a library in the Library 
Navigator when opening a lib.defs file can now be improved by creating an index file of 
the cellviews in the library. This can produce significant performance improvements for 
very large libraries on a network drive. The script for creating the index file is called 
mkindex.py and is located in the LinuxUtils folder. This feature is suitable for static 
libraries in which the list of views do not change.

• ER 53198 — A TCL function "tanner_new_testbench_proc" now runs, if defined, when 
a new testbench is created (from the <New> item in the Setup Simulation “Testbench” 
droplist) that allows the testbench to be prepopulated with desired setup. The TCL 
function is passed FOUR arguments: lib cell view testbench, and is documented on the 
“New Testbench” dialog box.

• ER 53416 — Reference Probe on the Simulation Toolbar has been changed to 
Differential Probe. In Differential Probe mode, the user clicks 2 nets for each probe 
created. The first net is the positive net and the second click is the negative net.

• ER 53728 — A new command "workspace setactive -corners" makes it easier to 
populate the Corners matrix. This command clears out existing corner data, and then 
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accepts a single Tcl argument that is a "list of lists". The first list is the list of corner 
names; subsequent lists each define a single row. For example:

workspace setactive -corners {
  {c1 c2 c3}
  {library {c:\tmp\test.lib} FF SS {FS SF}}
  {variable V1 1.0 1.1 1.2}
  {variable V2 {} 0:10:100}
  {temperature T1 30 40 50}
}

• ER 53729 — A new dropdown on a Parameter Variable in the Corners page allows easy 
selection of parameters defined in the Parameters page.

• ER 53754 — A Plot Options dialog box is now available via the context menu on the 
Plot Options column in the Results page in Setup Simulation. This dialog box provides a 
user interface to set various Plot Options such as titles, axis formats, line styles, and so 
forth.

• ER 53800 — Holding the Ctrl Key down when pressing the Add button in the Setup 
Simulation > Results page adds a new entry at the end of the table. Without holding the 
Ctrl key, the new entry is added below the currently selected row.

• ER 54494 — Running a custom TCL script on program startup/shutdown, and database 
open/close is now supported in all tools. Scripts may be located in a “scripts” folder in 
the database folder, in %AppData%\Tanner EDA (Windows), $HOME/.tanner/config 
(Linux), or in a folder given by an environment variable 
$TANNER_TCL_AUTOLOAD_DIR.
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• ER 54547 — The New Library command now requests a technology reference.

• ER 55176 — Performance of loading very large schematic views such as parasitic 
views or digital synthesized views is improved.

Enhancements for Tanner Designer
This section lists the enhancements available in this release of the Tanner Designer application.

• ER 54598 — Running a custom TCL script on program startup/shutdown, and database 
open/close is now supported in all tools. Scripts may be located in a “scripts” folder in 
the database folder, in %AppData%\Tanner EDA (Windows), $HOME/.tanner/config 
(Linux), or in a folder given by an environment variable 
$TANNER_TCL_AUTOLOAD_DIR.

Enhancements for Waveform Viewer
This section lists the enhancements available in this release of the Waveform Viewer 
application.

Table 2-2. S-Edit Script Order 

Program startup scripts run in the following 
order . . .

Design open scripts run in the following 
order . . .

1. The bindkey script file, 
schematic_bindkeys_utf8.tcl, is loaded from 
%appdata%\Tanner EDA (Windows) or 
$HOME/.tanner/config (Linux).

2. User scripts 
from$TANNER_TCL_AUTOLOAD_DIR/
startup.sedit folder. 
$TANNER_TCL_AUTOLOAD_DIR is a 
user defined environment variable containing 
a path.

3. User scripts from the folder in %appdata%/
Tanner EDA/scripts/startup.sedit (Windows) 
or $HOME/.tanner/config/scripts/
startup.sedit (Linux).

4. Command line scripts (–t <filename>) and 
command line TCL commands (–T <“TCL 
Commands”>) – in the order they appear on 
the command line.

5. Command line design open (lib.defs open).

1. The autoLoad.tanner script from each 
library folder.

2. Scripts in the ./scripts/open.design folder 
for each library folder.

3. Scripts in the .scripts/open.design folder 
in the lib.defs folder.

4. Scripts in the 
$TANNER_TCL_AUTOLOAD_DIR/
open.design.

5. Scripts in %appdata%/Tanner EDA/
scripts/open.design (Windows) or 
$HOME/.tanner/config/scripts/
open.design (Linux).
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• ER 54494 — Running a custom TCL script on program startup/shutdown, and database 
open/close is now supported in all tools. Scripts may be located in a “scripts” folder in 
the database folder, in %AppData%\Tanner EDA (Windows), $HOME/.tanner/config 
(Linux), or in a folder given by an environment variable 
$TANNER_TCL_AUTOLOAD_DIR.

Corrected Problems for L-Edit
This section lists the fixed defects in this release of the L-Edit application.

• DR 42964 — The Node Highlighting data folder is now correctly preserved. It is saved 
in the registry so changing it will not modify technology.

• DR 43662 — Fixed problem with pin markers in SDL becoming hidden.

• DR 48049 — Fixed problem where Prevent Violations mode of Rule-Aware layout did 
not always work.

• DR 51766 — Fixed “Highlight All” in the SDL Context menu, and renamed it to 
“Highlight Tree”.

• DR 52254 — Commands entered on the command line are now included in the log file 
saved to the TANNERLOGPATH environment variable location.

• DR 53022 — When wire end style is butt, and wire is selected, edit range around the 
ends should not become half the wire width.

• DR 53218 — L-Edit now preserves maximized state of cellview windows when 
opening a design.

• DR 53271 — The user is now prompted to save unsaved changes to the T-Cell cache 
when exiting L-Edit.

• DR 53626 — Zoom level is no longer reduced every time you close and reopen a cell.

• DR 53768 — TDI no longer checks floorplan and issues an error regarding boundary 
for synthesis only.

• DR 53873 — Fixed rotating curve polygon around base point with customized angle.

• DR 53788 — Removed screen flashing when opening and closing cellview windows 
when cellview windows are maximized. 

• DR 54005 — Fixed problem saving TDI Floorplan settings.

• DR 54076 — Instances names are now preserved when copy-and-paste to a different 
cell.

• DR 54132 — Fixed problems using the “Preserve my layer colors in registry” option. 
Fixed problems with “Reset  Layer Overrides”.
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• DR 54249 — Alignment operations will no longer move locked instances.

• DR 54386 — LLayer_SetRenderingAttribute now accepts fill-and outline pattern values 
greater than 15.

• DR 54414 — Significantly improved performance of “Save All” when there are many 
views to save by updating UI at the end of saving all cells rather than after saving each 
cell. Saving after a GDS import is the usual case to see an improvement.

• DR 54435 — Fixed font usage on Linux so italic and bold text appears correctly. This 
affected the display of bold font to indicate modified cells, italic font to indicate active 
net in SDL.

• DR 54449 — Technology is now marked as modified after GDSII import if a new layer 
is added as part of the GDS import.

• DR 54594 — L-Edit Rule-Aware layout no longer gives false errors for geometries in 
the hierarchy.

• DR 54692 — LCell_Unreserve with bSaveIfChanged=LFALSE now reverts cell 
contents when unreserving.

Corrected Problems for Library Manager
This section lists the fixed defects in this release of the Library Manager application.

• DR 46912 — Tool works too slowly when in recent list oflib.defs exists remote path.

• DR 49178 — Linux: Now able to write an alias name after writing path of a library to 
add.

• DR 51771 — Changing the order of libraries in Project Libraries pane should apply on 
Categories Pane also.

• DR 51781 — Copy/Delete/Rename library operations prints errors on X-
FAB_AMS_ref_flow design.

• DR 53219 — “Workspace info” commands have been added, similar to S-Edit.

• DR 53231 — UTF-8 symbols of library and cell names are shown as underscores in 
several dropdown components of LM dialog boxes.

• DR 53589 — There is now a separate checkbox in Appearance ribbon to show/hide 
lib.defs.

• DR 53663 — Drag and drop of a lib.defs file into command line open it instead of 
sourcing as a script.

• DR 53772 — Need to auto-refresh newly created, copied, and renamed libraries/cells/
views in managed project.
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• DR 53801 — Symbolic links to lib.defs files no longer result in incorrect relative path 
expansion.

• DR 54091 — Library Manager opens separate S-Edit/L-Edit during opening a view.

• DR 54338 — Name validation is now working during copying the category to another 
library.

• DR 54447 — Tool no longer incorrectly shows existing instances like unbound (in red) 
in Replace Instances dialog box.

Corrected Problems for Linux
This section lists the corrected problems available on Linux in this release.

• DR 53402 — Fixed problem using soft link to /home in the wine configuration directory  
while openinglib.defs.

Corrected Problems for Revision Control
This section lists the fixed defects for Revision Control in this release.

• DR 48913 — Library Manager Now auto commits lib.defs file after deleting library.

• DR 49224 — Library Manager View should not be in Uncommitted state after Revert to 
latest revision.

• DR 49730 — Library Manager SVN:SE+LE: Now able to revert to newer versions after 
reverting to some old version.

• DR 50832 — Library Manager P4+SVN+SOS: Update library now shows newly added 
categories in Categories Pane.

• DR 51378 — S-Edit SOS: When we create a copy of a cell with the "Manage Cell" 
option checked, S-Edit checks out the parent folder of the copied cell.

• DR 53028, 53029, 53030 — Library Manager S-Edit, L-Edit Unicode and special 
symbols support in Library Manager, S-Edit and L-Edit.

• DR 53554 — S-Edit SVN+SOS+P4: Revert is now working during rename of 
uncommitted views.

• DR 53580 — Library Manager lib.defs repo lock/unlock concurrent flow is fixed in 
SVN integration - conflicting state for lib.defs.

• DR 53588 — Library Manager now auto-refreshes managed lib.defs after explicit or 
implicit modification.

• DR 53771 — Library Manager needs to correct implicit commit of managed lib.defs 
during library rename operation.
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• DR 54035 — Library Manager Linux: Tools now recognize the Version Control when 
loaded lib.defs file is a symbolic link.

• DR 54804 — S-Edit SVN+P4+SOS: Performance opening designs under revision 
control is improved.

Corrected Problems for S-Edit
This section lists the fixed defects in this release of the S-Edit application.

• DR 25620 — S-Edit now preserves maximized state of cellview windows when 
opening a design.

• DR 50337 — Update All now recognizes newly added libraries into thelib.defs file. 
Libraries can be added to the lib.defs file by L-Edit, Library Manager, or manual edits.

• DR 52455 — Rotating a symbol to a swapped instance now only copies user modified 
properties, rather than all properties. Unmodified properties retain their default values.

• DR 52488 — Fixed problems with File > Image > Copy to Metafile.

• DR 52546 — Fixed Variable > Move Up/Move down in Setup 
Simulation > Corners.

• DR 52940 — Significantly improved performance opening large schematic views 
written by other tools. Also improved connectivity extraction performance of large 
designs with inherited connections, resulting in faster design check and netlisting. 

• DR 53180 — Fixed problems in File > Image > Copy Color Metafile to Clipboard.

• DR 53422 — When selecting instances of a symbol in a schematic, if no libraries are 
selected in the Library Navigator, we no longer modify the library selection.

• DR 53791 — Removed screen flashing when closing cellview windows when cellview 
windows are maximized. 

• DR 53815 — The group command now creates a cell in same library as the current cell, 
rather than the toplevel library.

• DR 53207 — Fixed application crashes that occasionally happened at the end of a 
simulation.

• DR 53145 — The color of small-signal parameter annotations can now be changed.

• DR 53643. 53856 — Corrected some situations where parameter annotations for OP 
Results were blank.

• DR 53705 — Enabled annotation of AFS Model and OP Parameters regardless of the 
setting for ‘Enable Waveform Probing’.
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• DR 53757 — Improved the display of Command window hotlinks for viewing 
simulation results files at the end of an AFS or Symphony simulation.

• DR 53816 — Hierarchy Navigator is now automatically updated for new or copied 
views.

• DR 54334, 53957 — Corrected situations that caused EZwave and S-Edit to become 
non-responsive when displaying new plots. Requires AMSV-2022.1 or a newer release.

• DR 54372 — Sweeps on the parameter sweep page are now written in the inner loop 
when writing corners.

• DR 54377 — Library names missing from Hierarchy Report have been restored.

• DR 54420 — In the Instance dialog box, typing into Cell Name updates the instance 
name the same as picking the cell name from the list.

• DR 54633 — Corrected simulation results annotation which would not display after 
closing the schematic views, closing S-Edit, and then relaunching to display.

• DR 54079 — Names are now required for expressions that are defined on the Setup 
Simulation > Results page.

• DR 54359 — A single corner is no longer written out as an altergroup. This improves 
compatibility with some simulators.

• DR 54362 — Help > Supported Models now displays the BSIM3 version number 
correctly.

• DR 54505 — Fixed Setup AFS Simulation: General > Results Viewing > Subcircuit 
Probe Level.

• DR 54540 — Corrected theSetup Simulation > Results page so that modified Plot 
Options take affect when a Replot operation is performed.

• DR 54546 — Display is now updated after changing hotspot size.

• DR 54554 — Adding a library to a design no longer causes S-Edit to revert to its default 
grid settings.

• DR 54564, 54610 — Fixed problems with differential voltage probing when descended 
into the design hierarchy.

• DR 54651 — When netlisting for LVS and S-Edit is already open with a cell different 
from the one to be netlisted for LVS, the correct hierarchy priority is now used, rather 
than the hierarchy priority of the active cell.

• DR 54714 — Added a new TD column in Setup Simulation > Results > Calculator 
Table for determining whether an expression measurement should be exported to 
Tanner Designer.
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• DR 54731 — Current probe now works even when selection box on the symbol doesn't 
enclose the pin.

• DR 54801 — The Property Navigator now preserves it’s scroll position when changing 
property values.

• DR 54915 — Resolved some issues that could lead to the error: Network server error 
(Poco error 10054).

• DR 54950 — Cached values for subcircuit back annotation now use doubles and are no 
affected by the DTOS setting. This fixes accuracy problems when summing up subcrcuit 
currents.

• DR 55146 — The position of the active tab in the tab order is now preserved when 
opening a design.

Corrected Problems for T-Spice
This section lists the fixed defects in this release of the T-Spice application.

• DR 47255 — Resolved a crash which was due to file handle resource limits when 
running Verilog-A and compact model simulations with highly nested and lengthy 
parameter sweeps.

• DR 53828 — When simulating in PSPICE mode (.options compatibility=pspice) 
corrected the model levels for EKV, level=5, and BSIM3.3, level = 7.

• DR 54023 — Fixed problem where DC monte=<val> produces a histogram but does not 
output MC log or measure log.

• DR 54107 — Fixed a problem with invalid text display (screen trash) in the Simulation 
Status window.

• DR 54587 — Corrected the plot outputs VP(), VM(), IP(), and IM() which were wrong 
(swapped) relative to the selection of option ACOUT = 0 or 1.

• DR 54863 — Removed an invalid warning message when multiple search option 
commands are used, which is a valid way to define multiple directories to search for.lib 
and .include files.

Corrected Problems for Tanner Designer
This section lists the fixed defects in this release of the Tanner Designer application.

• DR 53820 — Fixed worksheet names under Linux to not include illegal characters, such 
as /, which was happening with naming option ‘Top parent directory name’.

• DR 54315 — Improved the display of Sweep Variables on the Measurements table, to 
include all levels of variable values.
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• DR 54776 — Corrected duplicate table row entries when a Tanner Designer project 
created under Linux is opened from Windows.

Corrected Problems for Waveform Viewer
This section lists the fixed defects in this release of the Waveform Viewer application.

• DR 53450 — Fixed unhandled exception error on TCL command [measure risetime/
falltime ].
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Global Customer Support and Success
A support contract with Siemens Digital Industries Software is a valuable investment in your 
organization’s success. With a support contract, you have 24/7 access to the comprehensive and 
personalized Support Center portal.

Support Center features an extensive knowledge base to quickly troubleshoot issues by product 
and version. You can also download the latest releases, access the most up-to-date 
documentation, and submit a support case through a streamlined process.

https://support.sw.siemens.com

If your site is under a current support contract, but you do not have a Support Center login, 
register here:

https://support.sw.siemens.com/register

Documentation
These release notes and the accompanying Tanner Tools documentation are available through 
multiple resources.

View the Tanner Tools documentation from the following locations:

• Application help through the Help > Help and Manuals to invoke the InfoHub 
documentation portal.

• On Support Center under the Documentation tab for Tanner Tools releases.

https://support.sw.siemens.com
https://support.sw.siemens.com/register
https://support.mentor.com
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Third-Party Information

Details on open source and third-party software that may be included with this product are available in the
<your_software_installation_location>/legal directory.
Note - Viewing PDF files within a web browser causes some links not to function. Use HTML for full navigation.
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